Data Aggregator in DX NetOps CA Performance Management shows Degraded state due to Threshold Monitoring
search cancel

Data Aggregator in DX NetOps CA Performance Management shows Degraded state due to Threshold Monitoring

book

Article ID: 145186

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

How do I tell what is causing my Data Aggregator to go into a Degraded state?

Environment

DX NetOps CA Performance Management (CAPM) all Releases

Cause

When any given metric family takes over 50% of a poll cycle to complete, the threshold monitoring engine transitions to a degraded state.

At this point an event is generated on the Data Aggregator indicating that if the evaluations continue to take over 50% of a poll cycle, threshold evaluation will be disabled if this persists for 15 minutes. 

Resolution

Create an on-demand report for the Data Aggregator component for the following 2 variables.

We want to show the metrics by component so set the view type to be "Chart per Item with Multiple Metrics" then set the "Metric Calculate Level" to By component. 

Data Aggregator Event Calculation Times : Percent Of Poll Cycle To Complete - Maximum
Data Aggregator Event Calculation Times : Number Of Processed Timestamps - Average

Run the report for around the time frame that the threshold state was degraded

The report will show you which metric family is causing the event processing to take a long time.

You can then adjust the amount of event thresholding you are doing on that metric family to reduce the load. 

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/performance-management/22-2/using/events/threshold-monitoring-and-threshold-limiter-behavior.html