Lost SMF type 89 subtype 1 record after CARS installation for CCS
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Lost SMF type 89 subtype 1 record after CARS installation for CCS

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Article ID: 145079

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Updated On:

Products

COMMON SERVICES FOR Z/OS DATABASE MANAGEMENT SOLUTIONS FOR DB2 FOR Z/OS Easytrieve Report Generator for Common Services UNICENTER JCLCHECK COMMON COMPONENT LDAP SERVER FOR Z/OS Mainframe VM Product Manager CHORUS SOFTWARE MANAGER GRAPHICAL MANAGEMENT INTERFACE WEB ADMINISTRATOR FOR TOP SECRET MF - MISC OLD CODES GENERIC UNISERVICE II Output Management Web Viewer

Issue/Introduction

After installing CARS 1908 through CARS 1912 on our DEV systems we have had a problem with an SMF record no longer being reported.

We have a process that keeps track of the number of SMF type 89 subtype 1 records.  Normally we have 5 of these records created every half hour.

We noticed after the IPLs this week that had CAS9 maintenance installed, that we were now only seeing 4 SMF type 89 subtype 1 records being created.

 

Environment

Release : 14.1
Release: 15.0

Component : CAIRIM : CA Resource Initialization Manager(Comm)

Cause

This symptom it is most likely as result of a change introduced with CCS 14.1 PTF SO05852

Note: This change is included at the base CCS 15.0 level

The implementation of the PTF or the new CCS release accounts for the SMF89 subtype-1 count difference.


Depending on the options set on an LMP check (individual product controlled), it was possible that we (CCS) were automatically creating both SMF89 subtype-1 and subtype-2 records.

During our working with IBM on SCRT reporting, we were informed that including both of these subtypes in an SCRT report was not possible. As part of this PTF, we stopped automatically creating subtype-1 records on LMP checks.

So while we, as a "Common Service", have no use for subtype-1 records as they are not needed for SCRT reporting, individual products may choose to create their own subtype-1 records for their own usage. Thus you could still see subtype-1 records for certain products.

Resolution

There is no resolution as this is not a problem that needs fixing.