After MOM fails over, the EM Windows Service will not start
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After MOM fails over, the EM Windows Service will not start

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Article ID: 145063

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

After MOM failed over successfully, EM Service (Windows service) will not start. 


EMService log has no ERRORs but exception: 

INFO   | jvm 1    | java.io.FileNotFoundException: D:\Program Files\Broadcom_Products\CA APM\Introscope10.7.0.45\.\product\enterprisemanager\configuration\<number>.log (Access is denied)

 

Environment

Release : 10.8.0

Component : ENTERPRISE MANAGER

Cause

The Account assigned for EM Service does not have access to the Shared drive used for APM High Availability.
Seems like the user logged into launch the EMService (local account) does not have access /permission to the NAS drive.

Resolution

  1. Create a service account with (Login as service capabilities)
  2. Service accounts needs to have read and write access to Shared drive (between the MoM).
  3. Service accounts needs to have read /write access to log folder and CA APM folder and PGSQL, Workstation and all APM related folders.
  4. Introscope Service needs to register as Windows server. And it needs to be start with service account using service -> properties -> log on

Additional Information