User Not Able to Access Phoenix UI - Blank Page
search cancel

User Not Able to Access Phoenix UI - Blank Page

book

Article ID: 145045

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Setting the Phoenix UI (ppm_newux) theme causing issues for few users and not allowing to navigate.

Steps to Reproduce

  1.  Login to Clarity with Administration Privilege's
  2. Navigate to Administration --> UI Themes
  3. Select Phoenix UI (ppm_newux) and Save 

Note: If you have partitions in the system, then you can also set the Phoenix UI (ppm_newux) theme at the partition too

     4. Now try to login to Clarity and few users can complain they are getting the below error in the browser console and the UI renders partially 

Users are unable able to log in to Clarity, however the browser displays a blank page.

The UI Theme is set to the Phoenix UI.

When changing the theme to a Classic UI theme, such as Teal and Gray, the page does display.

Environment

Clarity PPM 15.x

Cause

There are two primary reason for the UI not to render properly

  • Run the below query to check if you get the output and these users are the ones who has the issues with UI rendering using Phoenix UI (ppm_newux) 

SELECT
 count(*)
FROM
 cmn_sec_users u
WHERE
 NOT EXISTS (
 SELECT
  NULL
 FROM
  CMN_MENU_ITEMS
 WHERE
  menu_item_level = 0
  AND is_favorite = 1
  AND principal_id = u.id )
 AND u.user_status_id = 200
 AND id>4999999;
 

Note: Please remove the count(*) and see the list of users impacted. 

  • Using Phoenix UI (ppm_newux) as theme, it tries to check if the favorite exists and it it finds a problem it throws an error mentioned above. This is a defect (DE55334)

 

The Favorites menu can cause corruption, preventing the page to load correctly.

If after changing the UI Theme from the Phoenix UI, the user is not able to click or manage links on the Favorites menu, this is an indication of corruption.

Resolution

Solution:

  • The defect DE55334 is fixed in Clarity version 15.9.2 and higher.
  • The recommended solution is to upgrade to the latest Clarity version.

 

Workaround for lower versions:

Workaround 1

1. Run the query:

select * from CMN_MENU_ITEMS where menu_item_level =0 and principal_id= <affected_user>

NOTE: These users who experience the issue does not have an entry in this table CMN_MENU_ITEMS 

2. Change the UI theme to non Phoenix UI Theme
3. Log in as the affected user
Go to Favorites > Add Current

Note: This will add an entry to the table.

Workaround 2

There item could be hidden for the user in the CMN_MENU_ITEMS table.

1. Run query:

select * from cmn_menu_items
where 
menu_item_level = 0 and principal_id = <affected_user_internal_id>';

If the is_hidden field is 1, change it to 0 per SQL approved SQL query provided by the Support team.

2. Make a backup of CMN_MENU_ITEMS

3. Run the query provided by the Support team.

 

Workaround 3: On Premise customers only 

  1. Stop all clarity services
  2. Navigate to path Clarity_home/webroot/ui/uif/js/ and take backup of clarity_main_min.js and keep outside clarity_home folder.
  3. Replace the attached clarity_main_min.js with the attached file  clarity_main_min.js under Clarity_home/webroot/ui/uif/js/
  4. Restart all the clarity services and ask the user to login and see if you are still getting the problem

Additional Information

See Phoenix Theme not Fully Rendering Classic UI Page for an another possible resolution. 

 

Attachments

clarity_main_min_1610538420044.js get_app