Installing PPM "XML Open Gateway Client" (XOG.exe) gives "Error 2739.Could not access JavaScript run time for custom action"

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Article ID: 145016

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Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The following error is received when attempting to complete the PPM "XML Open Gateway Client," for the "Windows Installer," which is run from a file called "XOG.exe."


CA PPM XML Open Gateway
Error 2739.Could not access JavaScript run time for custom action .




Cause

1) Follow the PPM 15.7 XOG client installation steps for Windows. 

See "XOG Client Installation."
https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/business-management/clarity-project-and-portfolio-management-ppm-on-premise/15-7/reference/xml-open-gateway-xog-development/xog-client-installation.html

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Download and Install the XOG Client
Follow these steps: 
1. Click Administration, General Settings, Client Downloads.
2. For the Windows operating system:
a) Click the Windows Installer Download link.
b) Save the XOG.exe file to a directory on your local computer.
c) Run the XOG.exe file and follow the on-screen instructions.
- - - 

2) After running XOG.exe, the "CA PPM XML Open Gateway" InstallShield Wizard for XOG comes up. Choose, Next to move through the Welcome screen, Next to accept the default install of CA PPM XML Open Gateway and at this point the error may come up.

Environment

CA PPM 15.7, installing XOG to a Windows 10 computer.

Resolution

There are a number of factors that may need to be done. The final resolution step in one case was to register the jscript.dll.

1) Open a Windows Administrator Command Prompt.

2) Navigate to the location where the latest jscript.dll was installed. Installing a current version of Java may have been a step completed recently prior to obtaining XOG.
In this case, the latest copy was located in C:\Windows\SysWOW64.

3) Run the command "regsvr32.exe jscript.dll".
There should be a confirmation message "RegSrvr32. DIIRegisterServer in jscript.dll succeeded."



NOTE: You must run this from an Administrator Command Prompt. Running from a regular Command Prompt will fail with this message:

"RegSrvr32. The module 'jscript.dll' was loaded but the call to DIIRegisterServer failed with error code 0x80004005."





4) Retry the XOG.exe installation, and it should complete that step.

Additional Information

If this procedure does not allow the XOG Windows client to install, then continue to troubleshoot as a Java/JavaScript issue.

For example, check that the JAVA_HOME path is populated in the Environment Variables, check that a current/correct version of Java is installed, check that there are no conflicts with old versions and so on.

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