Importing an Agent using Asset Collector may not store all its Software information
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Importing an Agent using Asset Collector may not store all its Software information

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Article ID: 144979

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Updated On:

Products

CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager

Issue/Introduction

In order to import an Agent using Asset Collect, a XIU file can be used, which has the following structure:

<asset translator="ACBsFmt" version="1_0">
<asset>
             <general>    </general>
             <hardware>   </hardware>
             <software>
                              <package name="Adobe Photoshop 2020">
                              <attribute name="Pub">Adobe Systems Incorporated</attribute>
                              <attribute name="Ver">21.0.3</attribute>
             </software>

             <user>
                        <general>    </general>
                        <hardware>   </hardware>
                        <software>   </software>
             </user>
</asset>

Where the information of the machine, its hardware and software can be written and let Asset Collect to store it into the MDB, making it available on DSM Explorer.

When this is done it may be possible that not all the software being written in the script is actually stored in the MDB.

Environment

Client Automation 14.X

Cause

The software information of Agents is stored (among others) in 2 tables, first is the "ca_discovered_software", which holds the link between Agent and the software, and also on "ca_software_def", where is stored the detailed information of that specific software. Here is where a limitation is present, looking at the columns called 'name' and 'sw_version_label' (which hold the software name and its version) have a character limit, based to their data type, of 255 and 64:


If the software name or version written down in the XIU file have more than 255 or 64 characters respectively, the Agent will be stored correctly, but that specific software won't.

Resolution

Since XIU file is written manually, there is no validation made on the number of characters in each field.

The recommendation is to always keep the amount of characters as reduced as possible.