Rally - Error: The attachment could not be uploaded. The server may be temporarily unavailable.
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Rally - Error: The attachment could not be uploaded. The server may be temporarily unavailable.

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Article ID: 144949

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Updated On:

Products

Rally SaaS

Issue/Introduction

When uploading attachments, the following error is shown in a red flare in the application and you may be unable to attach a file to a work item:

The attachment could not be uploaded.  The server may be temporarily unavailable.  

Environment

Release : SAAS

Component : AGILE CENTRAL

Cause

Firewall Blocking Attachment

This error can be caused when there is a firewall or proxy on your network that is scanning attachments to ensure that content with personally identifiable material is not sent outside of the network.
In order to validate if this is an issue on the network or an issue with the application, perform the following steps:

  1. Using Chrome, open the user story you're wanting to make the attachment to
  2. From the Chrome vertical ellipses menu icon (⋮), choose More Tools -> Developer Tools
  3. Click the Network tab from the options where it says "Elements Console Sources Network"
  4. Attempt to attach your file
  5. You should see, in the bottom pane, a request pop up that says "richTextUploadAttachment.sp"; click that
  6. This presents a window to the right of that request.  Click the "Preview" option.
  7. A normal response would show something as follows:
{
    "status" : 0,
    "imageUrl" : "/slm/attachment/<OID>/my_file.txt",
    "fileName": "my_file.txt",
    "oid": "<OID>"
}


However, if the attachment is being denied by a firewall, you may see a message about the request being denied due to policy, content, etc.  This will likely be a firewall on your network denying that request.

 

Customer Managed Keys

This issue can also occur if there is an issue with Customer Managed Keys (CMK), so please let the support person know if your attachments are encrypted using CMK.

Resolution

In order to resolve this issue, it will be necessary to either remove the information that is triggering the blockage from the file or work with your network team to identify a way to attach the file to Rally.

 

Additional Information

keywords: agile central user story defect feature