TDM Portal installer ERRORS with BackupAppConf during upgrade
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TDM Portal installer ERRORS with BackupAppConf during upgrade

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Article ID: 144925

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Trying to upgrade TDM Portal and have got an issue which is blocking in installing the tool.



Getting below error in the installation log that got generated:
======================================================================
Action start 16:21:10: BackupAppConf.
Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.  Custom action BackupAppConf script error -2146828212, Microsoft VBScript runtime error: Path not found Line 11, Column 2,  
MSI (s) (50:8C) [16:23:24:951]: Product: CA Test Data Manager Portal -- Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.  Custom action BackupAppConf script error -2146828212, Microsoft VBScript runtime error: Path not found Line 11, Column 2, 
======================================================================

Environment

Test Data Manager
TDM Portal

Cause

The error message in installation log file says "..Path not found.." which could mean several reasons (path doesn't exists, path contains invalid characters, path is too long...).
The files/folders  found in the logs -  are backup directories stored inside the existing Portal installation folder caused file paths to be longer than Windows limit (248 characters) and that's why the installer failed to copy files during installation.

for example : C:\Users\TEMP.XXXXI.000\AppData ..... 

 In this particular example TEMP.XXXXI.000 is too much but TEMP.XXXXI.0 works.

So in general updating Portal with user names longer than 13 characters most probably fails with the same error.

Resolution

Here are the 3 options you have:

  1. Use a different user with  shorter user name.
  2. Remove backed up TEMP folders in AppData folder. These files may be hidden. ( C:\Users\TEMP.XXXXI.000\AppData\Local\Temp )
  3.  Enabling support for longer paths in the system . This require admin rights. 

Steps for #3: 

Open the Start menu, type regedit, and press Enter to launch the Registry Editor.

Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem.

Right-click the LongPathsEnabled value and select Modify.

Change the Value data from 0 to 1.

Click OK and restart your computer.

Note ** :  If the above does not resolve the issue,  you could also delete : "C:\Program Files\CA\CA Test Data Manager Portal\tomcat\webapps\TestDataManager" folder. 
 
Removing those backed up folders from TDM Portal installation folder and rerunning the installer, resolved the issue.