Change Detail Reports cause error messages in stdlog

book

Article ID: 144917

calendar_today

Updated On:

Products

CA Service Desk Manager SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Desk Manager - Mobile Application CA Service Desk Manager - Xtraction

Issue/Introduction

If performing a Detail Report for Changes, a block of errors including an error in BPMatt method is received for every Configuration Item (CI).


Setup to reproduce:
1. Configure a multitenancy environment
2. Create a tenant named "tenant2" that is a non-service-provider tenant, has no parent tenant, and no subtenants.
3. Create a Configuration Item called "ci5" which has the tenant set to "tenant2".
4. Create a Configuration Item called "ci6" which has the tenant set to "tenant2".
5. Create a relationship between ci5 and ci6 such that ci6 "is the child of" ci5.
6. Create a Change Order that has the tenant set to "tenant2".
7. Update the CI's for the Change Order such that ci5 and ci6 are attached.
8. Create a copy of the "Level 2 Analyst" role and name it "Level2AnalystCopy". For "Level2AnalystCopy", set the "Tenant Access" to "Contact's Tenant Group".
9. Create a copy of the "Administration" access type and name it "AdministrationCopy". Add the new role, Level2AnalystCopy, to that access type.
10. For AdministrationCopy access type, set the Reporting Role to Level2AnalystCopy.
11. Create a contact named user1tenant2, setting the tenant to "tenant2", contact type to "analyst", and access type set to AdministrationCopy.
12. Log in as usertenant2, set the role to Level2AnalystCopy, display the Change Order List, click on the "Change Order #" to view change order of that was created in step#6. Then, in the Related Tickets tab, in the Configuration Items subtab, opened the Filter and set Name to ci6, then clicked Search, then selected Reports dropdown and selected Detail.

Results in stdlog:
08/07 10:34:02.67 SDM171RU3pri report 10012 ERROR vdbsql.c 4619 SQL parse error: syntax error, unexpected $end at = ...
08/07 10:34:02.67 SDM171RU3pri report 10012 SIGNIFICANT vdbsql.c 4620 SELECT hier_parent , hier_child FROM Business_Management WHERE ( Business_Management.tenant IS NULL OR Business_Management.tenant = U'64722ECF87803C41B4ACC704FE92E115' ) AND hier_child =
08/07 10:34:02.67 SDM171RU3pri report 10012 ERROR bpmatt.c 397 syntax error, unexpected $end at = ... in BPMatt method
08/07 10:34:02.67 SDM171RU3pri report 10012 ERROR report.c 3303 Error 1 doing fetch of SELECT hier_parent, hier_child FROM Business_Management


 

Cause

The issue is confirmed to be a product defect. The defect ID is DE50413.

Environment

Release : 17.1

Component : SERVICE DESK MANAGER

Reported against: Service Desk Manager 17.1 RU3 and RU4.

Resolution

DE50413 is resolved in 17.1 RU6 (17.1.0.6) and 17.2 RU4 (17.2.0.4).