UIM CABI not running after upgrade to 9.2.0/20.1

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Article ID: 144895

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Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

Successfully updated the primary hub, UMP robot and CABI robot to 9.2.0 (or 20.1)

After deploying the 4.10/4.20 cabi probe to the cabi robot, the cabi.log file fills with errors indicating that it cannot connect to the cabi server:   https://<cabi robot name>/cabijs

From the _cabi.log file, it shows that the bundled cabi upgrade succeeded, but the wasp probe on the cabi robot is failing to start the cabijs webapp.  Lines similar to the following are repeatedly recorded in the cabi.log:

Feb 04 11:07:01:697 [main, cabi] waiting for cabi webapp @ https://<cabi robot name>/cabijs to start responding ... 
Feb 04 11:07:01:697 [main, cabi] checking url=https://<cabi robot name>/cabijs, timeAlreadyWaitedInSecs=0, maxTimeInSecs=600
Feb 04 11:07:01:869 [main, cabi] Not able to connect to url=https://<cabi robot name>/cabijs, timeAlreadyWaitedInSecs=0

From the wasp.log file, lines similar to the following are found regarding the start up of the cabijs webapp:

Feb 04 10:40:46:855 INFO  [Catalina-utility-1, org.apache.catalina.core.ContainerBase.[wasp-engine].[localhost].[/]] No Spring WebApplicationInitializer types detected on classpath
Feb 04 10:41:17:037 ERROR [Catalina-utility-1, org.apache.catalina.core.ContainerBase] startInternal() A child container failed during start
Feb 04 10:41:17:037 ERROR [Catalina-utility-1, org.apache.catalina.core.ContainerBase] java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[wasp-engine].StandardHost[localhost].StandardContext[/cabijs]]

Cause

Stale data in the <installpath>\Nimsoft\probes\service\wasp\work directory on the cabi robot after upgrading from cabi 3.32 to 4.10/4.20

Environment

Release : 9.2.0 / 20.1

Component : UIM - CABI

Resolution

Execute the following steps on the CABI robot:

1.  Deactivate the wasp probe
2.  Deactivate the cabi probe
3.  Delete the following directory and its contents on the CABI robot:

- <installPath>\Nimsoft\probes\service\wasp\work

4.  Activate the wasp probe
5.  When the PID and port columns for the wasp probe both have values, activate the cabi probe
6.  When the PID and port columns for the cabi probe have values, clear the browser cache from the beginning of time, then verify that the CABI server URL can be accessed directly from the browser:  https://<CABI servername>/cabijs


Additional Information

It may be necessary to delete the wasp probe's work directory on the UMP robot(s) as well in order to be able to access the CABI server from the UMP portal.  Those steps are as follows on all UMP robots:

1.  Deactivate the wasp probe
2.  Delete the following directory and its contents:

- <installPath>\Nimsoft\probes\service\wasp\work

3.  Activate the wasp probe

In large UIM environments, it may also be necessary to add a new key to the setup section of the UMP wasp.cfg file to specify the robot where the cabi probe is deployed to prevent the UMP wasp probe from timing out while attempting to locate the cabi probe.  From the wasp probe's Raw Configure GUI, select the setup folder from the left-hand pane, then Add the new key value in the right-hand pane:

cabi = <UIM address of the cabi robot>

where the <UIM address of the cabi robot> is built as follows:

/<domain name>/<primary hub name>/<cabi robot name>/cabi

For example:

/UIM/primary_hub/cabi_robot/cabi

Note that the UIM address is case sensitive.

Save the configuration change and restart the wasp probe on the UMP robot.  If there are multiple UMP robots, make the same configuration change on each.