CA Spectrum - CABI Jaspersoft SSO Integration is not working

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Article ID: 144815

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Updated On:

Products

CA Spectrum

Issue/Introduction

Integrated Oneclick server to CABI Jaspersoft, after integration the SSO does not work.

Unable to login jaspersoft directly from OneClick Administrator page, need to enter credentials.

Cause

The timestamp of spectrum.jks & spectrum.properties files is NOT same in SMR & Jasper server.

Environment

Release : 10.X

Component : Spectrum Core / SpectroSERVER

Resolution

If SSO is enabled, verify the timestamp of spectrum.jks & spectrum.properties files in same in the below locations of SpectroSERVER & Jasper Server.

a) $Specroot\tomcat\webapps\spectrum\repmgr\admin

b) $CABIroot\apache-tomcat\webapps\jasperserver-pro\WEB-INF\config.


If not same, then copy both files from location a -> b and restart Jasper server.

Additional Information

Sometimes issue occurs when user does not follow below steps.

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/spectrum/10-3-2/installing-and-upgrading/install-report-manager/ca-spectrum-with-unified-dashboards-and-reporting-for-infrastructure-management/ca-spectrum-and-cabi-jasperreports-server-integration-for-unified-dashboards-and-reporting.html

5) Using the command prompt, run the following command: 
<CABI Install folder path>\java\bin\java -jar <spectrumConfigInstaller.jar file path>\spectrumConfigInstaller.jar -install