KeyCloak Error when Starting IAM Service
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Article ID: 144785
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Updated On:
Products
CA Cloud Test Mobile
CA Application Test
Issue/Introduction
Not able to start IAM as a service, getting keycloak error
Cause
Multiple instances of IAM service running.
Environment
Release : 10.5
Component : CA Service Virtualization
Resolution
When starting IAM getting a keycloak error.
Was on DevTest 10.4.0, did an uninstall, installed DevTest 10.5.0 to a new folder.
Noticed that there were many DevTest 10.5.0 IAM services running.
Had to do a kill -9 on each of the processes running.
Then noticed the DevTest 10.5.0 IAM server.log was being written out to the DevTest 10.4.0 standalone folder.
Removed all of the DevTest 10.4.0 folders.
Was then able to start IAM and log in with no errors.
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