Spectrum is not updating interface information for Viptela devices

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Article ID: 144749

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Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

  • Spectrum is not updating interface information for Viptela devices.
  • This is causing a mismatch between CAPC and Spectrum for these devices.

Cause

  • When reconfigurations are enabled in Spectrum, Spectrum monitors ifnumber, ifStackLastChange, and ifTableLastChange.
  • Unfortunately ifTableLastChange and ifStackLastChange are not supported by Viptela.
  • When the ifTable on the device changes, Viptela does not update ifnumber. 
  • Since those 3 attributes are not changing, this causes an index mismatch between CAPC and Spectrum since there is no trigger mechanism for Spectrum to perform an automatic rediscovery of the interfaces. 
 

Environment

Release : 10.3.2 10.4 10.4.1

Component : Spectrum Core / SpectroSERVER

Resolution

1.  Open a ticket with Viptela to have them support ifStackLastChange and ifTableLastChange as these are standard mib 2
2.  Find out if the Viptela devices support any form of change management traps. If you can get a trap to fire from the devices when there is an ifTable change we could then use an event procedure on that trap in Spectrum to trigger the reconfiguration. 
3.  Create a script that runs in cron to reconfigure the devices on a schedule basis (daily, weekly, monthly).

Additional Information

Example reconfiguration script:

@echo off
 
SET VNMSH=C:\Spectrum\vnmsh
 
pushd %VNMSH%
 
%VNMSH%\connect
 
%VNMSH%\show models mth=0x6a40011 >C:\Windows\Temp\mh.txt
 
for /F "tokens=1-4 skip=1" %%A in (C:\Windows\Temp\mh.txt) do %VNMSH%\update action=0x1000e mh=%%A