Forecast doesn't work after modifycert on EEM servers

book

Article ID: 144741

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation Agent CA Workload Automation AE

Issue/Introduction

In order to install WCC 11.4 SP7  we were asked to run the modifycert command on the EEM servers in order to set SHA1 and keylength of 2048. 

But since the forecast command no longer works on the autosys servers attached to the same EEM servers.

$ forecast

ERROR: [0xf02e2b40] CertificateReader :: loadPEM: etpki_pem_file_to_cert failed [errorcode: -1]
log4cxx: No appender could be found for logger (SafeCertificateReader).
log4cxx: Please initialize the log4cxx system properly.
CAUAJM_E_10436 Security server unreachable or invalid authentication certificate file.
CAUAJM_E_10434 Error initiating security session.
CAUAJM_E_10437 Detailed Error Information:
[EE_BADOBJECT Bad Object]
[ISE_BADOBJECT bad object data]
[Authenticate Error: Authentication Failed]
[Identity Attempted:]
[CertificateReader :: loadPEM - cannot read certificate]
CAUAJM_E_40003 The specified parameters are not valid.
CA WAAE Forecast Utility

Environment

Release : 11.3.6

Component : CA Workload Automation AE (AutoSys)

Resolution

Run autosys_secure to generate new certificate