CA Web Viewer 12.1 report date filtering differs from CA View Results
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CA Web Viewer 12.1 report date filtering differs from CA View Results

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Article ID: 144573

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Updated On:

Products

Output Management Web Viewer

Issue/Introduction

Reports produced on CA-View ---- with time zone on z/OS LPAR set to mainframe date/time zone.
Viewing same reports with Web Viewer, Web Viewer uses the date/time zone settings from the user's PC.

On CA-View; if reports for the last 16 hours (for example) are requested - it will show reports created within last 16 hours.

If the same criteria is used on  Web Viewer - it will show reports created in last 16 hours - based on time zone of the local PC

If the CA View mainframe LPAR  is set to different time zone from the users PC,  then the results will differ from CA-View query..

Is there a fix for this?

 

Environment

Release : 12.1

Component : CA OUTPUT MANAGEMENT WEB VIEWER FOR ALL PLATFORMS
CA View

Cause

This is caused when local and remote systems are physically located in different time zones.
This is not an issue that is unique to mainframe, Windows, Linux ,etc..

Resolution

The possible difference is dependent on the choice of date filtering.
If the "From nnn days" from there to the is used, there could be a situation where the PC time could cause the requested day to be different, if there are enough hours different from the mainframe CA View being queried.​

If the "Between and " filter is used, that will dictate what reports are returned from CA View explicitly by those dates as defined in CA View.

Since Web Viewer has no way of knowing the time difference between the user and the mainframe system where any particular CA View resides, there is no way the time difference can be converted to change the date range being requested, therefore using the "From" option will always use the current day on the PC for the query.