TDM: Unable to Open FDM Fast Data Maker (ORA-00942 table or view does not exists)

book

Article ID: 144566

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

After installing the TDM portal and importing the license file into TDM, the following error is encountered when opening up FDM:

"Failed to determine licence usage
Database Fatal Error Message: ORA-00942 table or view does not exists."

TDM Portal, GTSubset and FDM are working. 

Cause

The database user (GTREP) does not have privileges granted.

Environment

Release : 4.8

Component : CA Test Data Manager - Datamaker

Resolution

Be sure to grant the following privileges to the GTREP user:

ALTER ANY PROCEDURE
ALTER ANY TABLE
CREATE ANY INDEX
CREATE ANY PROCEDURE
CREATE ANY SEQUENCE
CREATE ANY TABLE
CREATE ANY VIEW
CREATE SESSION
CREATE USER
DROP USER
GRANT ANY PRIVILEGE
GRANT ANY ROLE
INSERT ANY TABLE
LOCK ANY TABLE

Additional Information

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/continuous-testing/test-data-management/4-8-1/installing/install-test-data-manager/install-the-repository.html