sybase monitoring is flooding the database with multiple connections
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sybase monitoring is flooding the database with multiple connections

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Article ID: 144519

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

We have configured Sybase monitoring for one of our customer's Sybase databases. However, the customers are complaining that the users are not able to access the DB as the our Sybase monitoring profile is flooding the DB with a high number of connections, around 600+. We have checked from our end and the Sybase monitoring has been configured correctly.

Additionally, we notice this database server robot is visible in the UIM console however when we click the robot the robot is empty and we need to actually restart the nimsoft service and then the probes will be visible. However, after a short period of time the probes go missing again.

Environment

  • Release: UIM 9.x or higher
  • Component : UIM - SYBASE
  • Sybase probe version: 4.31
  • Sybase Adaptive Server Enterprise/15.7/EBF 27353 SMP SP139 /P/x86_64/Enterprise Linux/ase157sp138x/4041/64-bit/FBO/Tue Aug  8 05:53:20 2017|
  • Sybase 16
  • hub v9.33

Cause

  • access/permissions and/or Sybase DB patches
  • log_size checkpoint (in a particular case)

Resolution

Please see:

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/sybase-sybase-monitoring/sybase-ac-configuration/sybase-ac-gui-reference.html

 User ID: specifies the authorized user identification code to the server.
 
The user MUST HAVE access to run selects against syslisteners.

   "SELECT permission denied on column address_info of object syslisteners, database master, owner dbo"

Check to see if you can run the following as the current database user or an admin user?

   select address_info from syslisteners

Object rights required:

    sysdatabases
    spt_values
    sysusgaes
    sysprocesses
    syscurconfigs
    sysconfigures

As well as SELECT permission  on column address_info of object syslisteners, database master.

Additional Information

Double check the sybase probe requirements at:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/sybase-sybase-monitoring/sybase-sybase-monitoring-release-notes.html

...especially these sections:

- Installation Considerations
- Configure Sybase Library Path
- User ID Authorization
- Advanced Mode
- ASE Configuration
- Migration Considerations
- Troubleshooting
- Limitations
- Known Issues and Workarounds

1)  Go to the hub server where the robot is located and stop the Nimsoft robot watcher service
2)  Go to to the DB server and stop the Nimsoft service on the client server
3)  cd to ...\Nimsoft\hub and take a backup copy of the robot.sds file
4)  Remove the robot.sds (robot.sds will get recreated upon robot startup)
5)  Start the Nimsoft robot watcher service on the hub server
6)  Start the Nimsoft robot watcher service on the DB server
7)  Deactivate the sybase probe
8)  Deactivate the robot
9)  Delete the robot 'niscache' folder
10) Activate the robot
11) Activate the sybase probe

Ask your Sybase DBA to make sure the Sybase Database server is up to date on all patches and patch if necessary. 

If you disabled the log_size checkpoint in the sybase probe, reenable the checkpoint after the Sybase database server is patched and restarted.

Afterward, there should be no further incidents of multiple Monitoring ID sessions on that respective DB server.

For the other issue in this environment as described, with robot selected but no probes showing in the view, note that the the previous hub version was causing these types of issues. This was a known issue in hub 9.33.

As part of hub defect DE459104, deviceId was used for checking robot uniqueness at hub level to handle robot name change. This caused issues in IM in certain environments where there was a possibility of duplicate deviceIDs. 

To resolve this issue in the context of the sybase environment and multiple connection issues, download and deploy hub v9.33_HF11.

1. Import the zip into the local archive.
2. Deploy the imported package to the Primary hub robot system and other hubs.

After deployment of the hub package, clear the niscache folder and Robot Device ID again and restart the robot, and this robot/probe display issue should be resolved.