Incorrect login credentials freeze the Applications Manager Client
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Article ID: 144484
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Updated On:
Products
CA Automic Applications Manager (AM)
Issue/Introduction
Logging into Applications Manager Java Client with a incorrect password results in the Client freezing or locking up.
Additionally, the below error can be seen in the RmiServer<timestamp>.log and/or client logs:
ErrorMsg: AwE-9999 Internal error Details: null java.lang.ClassNotFoundException: oracle.jdbc.OracleDatabaseException at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) .. ..
Environment
Release : 9.3, 9.3.1
Component : APPLICATIONS MANAGER
Cause
Client jars directory is missing the ojdbc*.jar which should be automatically downloaded from master's classes directory during initial successful client login.
Resolution
Workaround: Manually move a copy of the ojdbc*.jar from the master's $AW_HOME/web/classes or %AW_HOME%\web\classes (Windows) directory to the client's jars directory. The jars directory is located in the same directory as the RunClient.jar file.
Solution: This has been resolved with the release of 9.3.2.