TLSv1.2 Compatibility with DevTest

book

Article ID: 14441

calendar_today

Updated On:

Products

CA Application Test Service Virtualization CA Continuous Application Insight (PathFinder)

Issue/Introduction

Is TLSv1.2 compatible with DevTest?

Cause

N/A

Environment

All Supported DevTest releases and platforms.

Resolution

 TLSv1.2 was not enabled in Java 7 until update 95.  

Versions 10.3.0, 10.4.0 and 10.5.0 are delivered with Java 8 and TLSv1.2 is enabled by default.

Starting with DevTest 10.6.0 we deliver OpenJDK.

You specify to use TLSv1.2 by putting the below property in the local.properties file of where your DevTest components run:

https.protocols=TLSv1.2