Creating new HEAT options in xFLOW
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Creating new HEAT options in xFLOW

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Article ID: 144385

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

When trying to create/add  a new heat attribute into the "Default Heat Configuration for Incident"  for example  , it runs into the error , for example :

 

Environment

Release : 17.2

Component : XFLOW INTERFACE FOR SDM

Cause

It doesn't put the correct information in Condition field here 

Resolution

The correct information which should put into Condition field here should be :


customer.organization.name=\'Office of Information Services\' 




When creating a new heat attribute , which provides the constraints for the ticket with its affected user is in 'Office of Information Services'  organization .

Here is the explaination about how to come up with this data constraint in service desk :

At the Service Desk Object layer , the SD requests/incidents/problems tickets , it is stored in cr object . so i did the following command to get output to check cr object's attributes on SD server machine :

bop_sinfo -a cr > cr.txt

using notepad to check cr.txt and find the following :

customer             SREL -> cnt.id REQUIRED DISPLAY_NAME "Affected End User"

From above , you can see in cr object , customer attribute stores the information for a ticket's "affected end user" and it refers to cnt object . So do the following next :

bop_sinfo -a cnt > cnt.txt

and then examine cnt.txt and find the following :

organization         SREL -> org.id DISPLAY_NAME "Organization"

From above , you can see that a contact ( i.e. the "affected end user" here )'s organization information is stored in organization attribute of cnt object and it refers to org object . and then do the following next :

bop_sinfo -a org > org.txt

to examine org.txt and find the following :

name                 STRING(100) REQUIRED DISPLAY_NAME "Organization"


From that , you see that the organization's name is stored in name attribute of org object .


So , by putting all above together , you know that : to retrieve ( or constraint ) the SD tickets with the "Affected End User" in the 'Office of Information Services' organization , you will need to use the following for it :

customer.organization.name=\'Office of Information Services\' 

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