All the virtual services disappeared from the VSE
book
Article ID: 144374
calendar_today
Updated On:
Products
CA Cloud Test Mobile
CA Application Test
Issue/Introduction
All the virtual services disappeared
Environment
Release : 10.5
Component : CA Service Virtualization
Cause
Had restarted the Portal because it was running slow and the Registry ran out of memory.
Resolution
ps -aef | grep RegistryService
Results showed there were 3 RegistryService processes running.
Kill all three processes.
cd DEVTEST_HOME/tmp folder and saw many *.hprof files.
Removed all hprof files.
Reviewed the registry.log and could see memory errors.
Edited the DEVTEST_HOME/bin/RegistryService.vmoptions file and changed to start with 2g of memory.
Edited the DEVTEST_HOME/bin/VirtualServiceEnvironmentService.vmoptions file and changed to start with 2g of memory.
Started the Registry, Portal, Coordinator and Simulator.
Started the VSE.
Was then able to see all the VSMs running on the VSE.
The culprit here was the Registry, it had run out of memory and had a domino effect on the rest of the DevTest services.
Feedback
thumb_up
Yes
thumb_down
No