Getting error when trying to run a CABI/Jasper report Ad hoc report
search cancel

Getting error when trying to run a CABI/Jasper report Ad hoc report

book

Article ID: 144359

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I'm seeing errors when I try to run a report in CABI that only has maybe 13 rows of data but I get an error telling me:

"Data was truncated. System row limit exceeded: 200000."

I'm trying to find out why this error is happening when I'm basically pulling a report of all windows servers in our environment with over 90% CPU usage.
I'd like to see more details of the error if possible so I can make the needed changes to lower the row limit, if needed.

 

Environment

UIM 8.x 9.x
CABI 3.X 4.x

Cause

Jasperserver has a row limit set by default for 200000 of adhoc reporting.
This is configurable to change.

Resolution

the limits you are running into are part of the jasperserver report engine that CABI is based on.

Please see the below two links on how to change these values:

https://community.jaspersoft.com/wiki/ad-hoc-row-limit


And while you are at it, you probably need to extend the query timeout :

https://community.jaspersoft.com/documentation/jasperreports-server-administration-guide/v550/configuring-ad-hoc