CA WA Agent : Mapped network drive unavailable in jobs
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CA WA Agent : Mapped network drive unavailable in jobs

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Article ID: 144266

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent Autosys Workload Automation CA Workload Automation DE - System Agent (dSeries)

Issue/Introduction

When a job runs from the CA WA Agent the Network mounted or mapped drives are not available.  The Jobs may show following error:

Unavailable  F:        \\example.com\share_path
Microsoft Windows Network

The drives are accessible when user logs in to the Windows System.

Environment

Workload Automation System Agent

OS: Windows OS

Cause

CA WA Agent runs as a service in Windows OS.  The network mapped drives are not available to background services.  It is recommended to use Universal Naming Convention or UNC path instead of drive letters.  Due to various security issues the newer Windows OS do not allow drive letters to be easily accessible by services.

Resolution

Use UNC path or script to run the jobs.  If using a script, mount the drives, then run the command or scripts.
It is recommended to unmount the drives after jobs have completed.  Use drives letter are not currently mapped or used by other users.

Example:

ECHO ON
net use x: \\windows_host\sharename
command1

command2
net use x: /delete
ECHO OFF

Additional Information

Refer to following links for additional information.  

Mapped drives are not available from an elevated prompt


Windows Service Accessing Mapped Drives

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