UIM APMGTW probe dropping QoS messages from Secondary Hub

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Article ID: 144213

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Updated On:

Products

NIMSOFT PROBES DX Infrastructure Management

Issue/Introduction

I see the below messages from the apmgtw (3.22) probe log, regarding QoS messages from our new Secondary Hub. 

[Thread-2, apmgtw] Dropping QoS Message {informix : QOS_INFORMIX_DBSPACE_MIRROR_RECOVERING} as apmQosMessageFormat is not found for qos QOS_INFORMIX_DBSPACE_MIRROR_RECOVERING 

[Thread-2, apmgtw] Dropping QoS Message {informix : QOS_INFORMIX_DBSPACE_MIRROR_OFFLINE} as apmQosMessageFormat is not found for qos QOS_INFORMIX_DBSPACE_MIRROR_OFFLINE 

... [pool-8-thread-1, apmgtw] apmgtw Subsrcibe success

Cause

- apmgtw configuration

Environment

- apmgtw v3.22

Component : UIM - APMGTW

Resolution

Here is an example of the steps for configuration for a given probe, the weblogic probe, just do the same for whichever probe is having their QOS dropped from the apmgtw.

Please follow the steps below to configure the metrics.

You can find the same information regarding metrics for each and every probe  - you can search for the available metrics that will be helpful to configure the probe. 

*********************************** STEP 1 *********************************************

qosdefinitions.txt

Add entry like below if not available in this file.

weblogic.QOS_WEBLOGIC_POOLSIZE.Pool Size.Number.Number
weblogic.QOS_WEBLOGIC_HEAP_MEMORY_FREE_PCT.Heap Memory Free PCT.Percent.%

*********************************** STEP 2 *********************************************

qos.txt

Add entry like below if not available in this file.

weblogic.QOS_WEBLOGIC_POOLSIZE={host}:Pool Size
weblogic.QOS_WEBLOGIC_HEAP_MEMORY_FREE_PCT={host}:Heap Memory Free PCT

*********************************** STEP 3 *********************************************

qos.properties or qosbackup.properties

1. Search for "Probe Groups" generally in the starting of this file
2. Add entry like below:

probe.group.weblogic=Application|Weblogic

3. Now we need to define the format of QoS definitions:
Search for "format.weblogic" and if not exists, add below in specified format.

format.weblogic.QOS_WEBLOGIC_POOLSIZE={host}:Pool Size
format.weblogic.QOS_WEBLOGIC_HEAP_MEMORY_FREE_PCT={host}:Heap Memory Free PCT

4. Now Deactivate and Activate the probe.

5. Open the Admin Console GUI and in the left tree pane the "Available Probes" option should be visible for the particular probe.

And now you should able to configure the required metrics.

Note: If still have no Metrics, please go to Step 4

************************************ STEP 4 *********************************************

1. Open the Admin Console GUI and configure the apmgtw probe.
2. Save the configuration and then manually deactivate and active the probe.
3. Wait for 1~2 mins and open the Admin Console GUI, now in left tree pane "Available Probes" option should be visible.
4. Expand and then click on the weblogic probe - the defined QoS should be visible in GUI.
5. Enable the 2 QoS and save the probe. Manually deactivate and activate the probe.
6. Verify this on probe CFG file that weblogic QoS is there. 

Troubleshooting

Also, as per:
https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/apmgtw-ca-apm-gateway/apmgtw-ac-configuration.html

- Make sure you have all the 'Selected hosts' and 'Selected origins' configured via the Admin Console.

- In probes.txt file, add the list of probes for which apmgtw probe is not collecting data.

- Lastly, review the troubleshooting section in the apmgtw Help doc.

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/apmgtw-ca-apm-gateway/apmgtw-ca-apm-gateway-release-notes.html#concept.dita_7656d131730d4f78933996ac39501ffc960a060f_Troubleshooting