Dropdown of WorkflowTask statuses is not displayed in the Xflow interface

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Article ID: 144159

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

Workflow tasks status cannot be edited in Xflow interface, the dropdown is not displayed, it only shows the existing status, Service Desk interface allow the edition of the workflow status without issue, also there are no errors in the application or logs of Xfow or Service Desk.

Cause

The configuration for the workflow status field was set to read only in the configuration settings of the Xflow interface on Service Desk

Environment

Release : 17.2

Component : XFLOW INTERFACE FOR SDM

Resolution

Modify the configuration settings as follow

  1. Log in Service Desk with an adminstrator account.
  2. Go to Xflow interface->View configuration->Detail view->RE/IN/PR/WF task.
  3. A list with the objects will be displayed, found "status" and click on it.
  4. Uncheck the read only value for the status of the task and save it.