Aborting request after trying 3 (NX_DB_RECONNECT_ATTEMPTS) times
search cancel

Aborting request after trying 3 (NX_DB_RECONNECT_ATTEMPTS) times

book

Article ID: 144070

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

We are getting aborting request after trying 3 times. how can we increase the number of attempts SDM tries?

Line 1203: 01/29 00:16:24.40 SDMHostName bpvirtdb_srvr        2284 ERROR        vdbagent.c             852 Aborting request after trying 3 (NX_DB_RECONNECT_ATTEMPTS) times due to database connectivity problems for agent select5

 

Environment

Release : 17.2

Component : SERVICE DESK MANAGER

Cause

SDM option that controls this is  @NX_VIRTDB_RECONNECT_RETRY, it is the maximum number of attempts to allow for retrying queries that have SQL Connection problem.


SDM options around such connection/retry configuration are below:

@NX_VIRTDB_RECONNECT_RETRY
Maximum number of attemts to allow for retrying querys that have SQL connection problems. Default is 3.

@NX_VIRTDB_RECONNECT_WAIT
How long to wait in seconds to attempt to re-connect. Default is 15 seconds

@CONNECTION_RETRY_VAR
Number of times database agent tries to connect to a Database before returning  an error. Resolved from NX_SQL_CONNECTION_RETRY. Default is 5. 

@CONNECTION_WAIT_VAR
Number of microseconds that a database agent waits before retrying a connection  to a Database. Resolved from NX_SQL_CONNECTION_WAIT. Default is 500000. 

Resolution


Normally we do not need these to be changed, however, if there is a need to change them, they can be.  It is also preferred that these be changed/installed using pdm_options_mgr command:
https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=18247
https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=39873


Also keep in mind, extended delays/retries may not be sustainable in SDM (because we depend on record locks, internal triggers with in SDM etc.,)  which could cause further locking of SDM records etc.,  It's always better to get the root issue identified, as to why SQL Server was not available to start with.