Email from Netmaster is not working
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Email from Netmaster is not working

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Article ID: 144032

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Updated On:

Products

NetMaster Network Automation NetMaster Network Management for SNA NetMaster Network Management for TCP/IP NetMaster File Transfer Management SOLVE:Access Session Management SOLVE:Operations Automation SOLVE:FTS

Issue/Introduction

I am trying to email data using the $PSEMAIL printer option.  I see the output in a DD in my Netmaster started task. 
Do I need to release this to CSSMTP for the email to be processed or should it happen behind the scenes. 
I am not receiving my email or seeing being processed by CSSMTP.  

 

Environment

Release : 12.1 and higher
Component : CA NetMaster Suite

Release 5.0
SOLVE:Access

Release 11.9
SOLVE:Operations Automation

Cause

SMTP server is not active or problem with EXIT DATA

Resolution

1. Verify that SMTP or CSSMTP is active on the local system as Netmaster uses this for email processing.

 

2. In $PSEMAIL (and any additional email definitions that may have been customized for sending an email from the product region), the EXIT DATA must contain an SMTP parameter that matches the STC name of the SMTP server.
   The default value is SMTP.  Any other value must be defined.

Whether the mail proc in use is SMTP or CSSMTP, the STC name itself is what Netmaster / SOLVE looks for.

Example:

 Printer Name ... $PSEMAIL 

  Type ........... EXIT               (JES, VTAM, ALIAS, EXIT)

  Description .... Print to an email address                    

  Lower Case? .... YES                (Yes or No)

  Line Limit ..... 0                  (0 to 999999)

  Form Name .....+ $PSEMAIL   

ALIAS Printer

  Real Name .....+                    (Real printer name)

JES Printer

  Destination ....                    (destid.userid)

  Output Class ...                    (A to Z, 0 to 9)

VTAM Printer

  LU Name ........        

  Logmode ........    

EXIT

  Exit Name ...... $PSEM88Z

  Exit Data ...... JOB=CSSMTP HOST= NODE=