Device discovery fails with inaccessible state
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Device discovery fails with inaccessible state

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Article ID: 143914

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

DX NetOps Performance Management is not collecting metrics on the device because it is shown as inaccessible in the discovery profile history.

Environment

All supported DX NetOps Performance Management releases

Cause

Device and/or network issues.

Resolution

Try the following tests from the Data Collector that will be used to discover and manage the device. If both fail it validates the problem is environmental. Are there firewalls or ACL's or other tools controlling communications that might be causing the problem?

  1. Ping the device
  2. Run a MIB dump against device using the sapwalk2 utility or the snmpwalk command.

See more in the SNMP Querying Tools section of the documentation.

Additional Information

Also you can looking in the Data Aggregator logs:

INFO  | 6dcf-thread-3457 | AAAA-MM-DDTHH:MM:SS,NNN | DeviceDiscoveryTask | scovery.impl.DeviceDiscoveryTask 1723 | .im.aggregator.discovery |       | x.x.x.127 (64691546)'s primary IP was the network ID or broadcast address. It will be deleted.

It seems the IP address of the device (x.x.x.127) matches the broadcast IP address of one of the networks discovered in the device. We consider that as non valid IP address

Device information:

To confirm run snmpwalk:
snmpwalk -v 2c -c <ro_community_name> <ip_address> 1.3.6.1.2.1.4.20.1.3
 
 
Note: A good approach is looking for these 2 classes in karaf.log in Data Aggregator

DeviceDiscoveryTask - This is triggered when a discovery is issued 
ProfileDiscoveryTask - This is triggered when a profile rediscovery is needed because there have been 2 consecutive failed polls