Service Desk 17.2 - I was using a newer version of Java or Tomcat in a previous version but it reverted after upgrade

book

Article ID: 143911

calendar_today

Updated On:

Products

CA Service Desk Manager SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service KNOWLEDGE TOOLS CA Service Desk Manager - Mobile Application CA Service Desk Manager - Xtraction

Issue/Introduction

When we upgraded from 14 to 17.2 the upgrade reverted our tomcat references from 8.5.16 we were using to 8.5.6 and our references for JRE from 1.7.0_10 to 11.0.3.  I noticed with this in the pdm_tomcat log file that it was complaining about syntax in the server.xml file that was always there in 14 and worked fine.  Can we still use 8.5.16 and with JRE 11.0.3 ?

 

Environment

Release : 17.2

Component : SERVICE DESK MANAGER

Resolution

you can configure the service desk 17.2 to use 8.5.16  or any tomcat 8.5 based version. It doesn't  have much to do with the java version  that service desk is using here .

You  can still follow the servicedesk 14.1 documentation to configure service desk 17.2 to use tomcat 8.5.16

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/business-management/ca-service-management/14-1/implementing/implementing-ca-service-management-14-1/step-4-install-or-upgrade/implementing-ca-service-desk-manager/how-to-install-ca-sdm/step-3-install-other-components/install-and-configure-apache-tomcat-8-5-16.html



The steps to configure Service Desk to use the higher version of tomcat  (any tomcat 8.5 based version )  are the same for SD 14.1 or 17.0 or 17.1 or 17.2 .