Processes Not Showing Completion
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Processes Not Showing Completion

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Article ID: 143836

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

None of the GEL-based or flow-based processes are showing the message flag with details on the process completion.

 

Environment

Release : Clarity PPM 15.3 and higher

Component : CA PPM BUSINESS PROCESS MANAGEMENT

Cause

This is due to an additional configuration change needed in 15.3 or higher to see additional messaging types for processes as referenced in the 'New CSA Setting for Error Logging' in the CA PPM 15.3 Change Impact and Upgrade documentation:

A new CSA setting allows you to configure the level of logging that you want to see for process GEL scripts using <gel:log>. As a default, only errors or fatal logs are persisted in the BPM_ERRORS table. Accordingly, only error messages appear on the user interface. Messages that are not logged in BPM_ERRORS are not visible. You can change the default setting to allow logs for warnings and other informational messages so they also appear.

Resolution

For better performance, we recommend you keep the error logging at error. If you do want to see the message flag for completed processes, update Process Engine Persistence Log Level to Info in Log Configuration. Steps below:

  1. Log in to CSA or http://ClarityURL/niku/nu#action:security.logs (user needs to be administrator to have access to security.logs page)
  2. Click Home, Servers
  3. To edit the log information, click the Properties icon for the server.
  4. Click the Logs tab.
  5. Click the Edit Configuration sub tab.
  6. In the Properties section, complete the following field: "Process Engine Persistence Log Level"- set this to the 'Info' log level

     7. Save the changes

Note: You can also access the log configuration page from the Clarity application by replacing everything in the clarity url after action: with security.logs

Additional Information

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