Custom field data is not saved in Service Desk Manager custom form

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Article ID: 143749

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Custom field data is not saved in Service Desk Manager custom form

 

Cause

The Attributes in a form are in lowercases but schema designer shows capital letters in the attribute name. We noticed the schema designer shows:

zCustomAttribute1

but the form shows in the source code:

attr=zcustomattribute1

 

causing the issue to occur.

Environment

Release : 17.2

Component : SERVICE DESK MANAGER

Resolution

SDM is case sensitive so the form source code must be updated to use the same case being used in the schema designer.

Steps:

1. Open WSP > Open Form > Select the form being used

2. Click on the Source tab at the bottom.

3. Search for the attribute. ex: 

<PDM_MACRO name=dtlCheckbox hdr="Attribute Label" attr="zcustomattribute1">

4. Change the attribute value to the one showed in schema designer. ex:

<PDM_MACRO name=dtlCheckbox hdr="Attribute Label" attr="zCustomAttribute1">

5. Save Changes and Publish

6. Clear server cache by running: pdm_webcache -H