Why has the Spectrum & CAPM Integration Event Polling Service has been disabled automatically?
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Why has the Spectrum & CAPM Integration Event Polling Service has been disabled automatically?

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Article ID: 143739

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Updated On:

Products

CA Spectrum CA Performance Management - Usage and Administration

Issue/Introduction

When checking the Performance Center Integration page within the Spectrum Administration Web Page, users may notice that event polling has been disabled automatically.

Environment

Release : 21.2, 22.2

Component : Spectrum Integrations

Cause

This is due to Spectrum OneClick not being able to establish a connection with PM Device Manager for a five minute period.

Resolution

In the current code, if Spectrum cannot contact Device Manager for 5 minutes, Spectrum will automatically disable the event polling service. 
 
Presently, we do not have a mechanism to let users know when Spectrum is unable to contact Device Manager other than by seeing the following error message in the tomcat log file. 
 
(GlobalPool => NPCEventManagerWebserviceURLPoller) (NetqosEventLog) - (ERROR) - Unable to contact Event Manager - stopping all polling.
 
 
Development is working on generating an event on the VNM model which will notify users of this change. They are also looking into automatically re-enabling this service once contact has been re-established. This will be included in a future release of Spectrum.