Clicking on Catalog Offerings in Service Point raises an error on top right corner of browser

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Article ID: 143734

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog CA Service Desk Manager

Issue/Introduction

An error like this is seen in xFlow's IncidentMS.log file at the same them when you click on an offering link in Service Point

 

ERROR - 2019-04-05 18:17:23 [c.c.c.a.h.SdmBoplginMethodHelper] - Failed to get the EEM Artifact: AHD04023:Security error: get_bopsid/get_artifact (cnt:6C222631017FFA4E837E475CFC0F746C)
ERROR - 2019-04-05 18:17:23 [c.ca.casm.framework.util.CasmFuture] - Exception occurred, see call stack for more details: userid ()
java.util.concurrent.CompletionException: com.ca.casm.exception.CasmBaseException: Failed to get the EEM Artifact: AHD04023:Security error: get_bopsid/get_artifact (cnt:6C222631017FFA4E837E475CFC0F746C)
at java.base/java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:331)
at java.base/java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:346)
at java.base/java.util.concurrent.CompletableFuture.uniWhenComplete(CompletableFuture.java:870)
at java.base/java.util.concurrent.CompletableFuture$UniWhenComplete.tryFire(CompletableFuture.java:837)
at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)

Cause

This is an indication that SDM is not able to get an EEM token that Service Point / Catalog needs to get the integration working properly.

Environment

Release : 17.2

Component : SERVICE DESK MANAGER

Resolution

1) Restart SDM/Catalog/EEM should help with this.   

2) A work around might be to kill SDM's bopauth_nxd program  (pdm_kill bopauth_nxd)  on the SDM Background or Primary server.

3) Logout and login to Service Point again and click on Shopping Cart or the Offering, now the errors should not appear