DUAS: Support of Oracle 18c/19c

book

Article ID: 143726

calendar_today

Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

Is Oracle 18c supported with UVMS / Reporter / Manager for Oracle DB?

If so, what is the correct ojdbcX.jar file that should be used for Oracle 18c (12.2.02) when installing UVMS / Reporter / Manager for Oracle DB?

Environment

Release : 6.9

Component : DOLLAR UNIVERSE

Resolution

First of all, Oracle 18c (12.2.0.2) and Oracle 19c (12.2.0.3) will be supported starting on version 6.10.31 for UVMS / Reporter / Manager for Oracle DB that should be released by March 31th 2020.

Oracle 12c (12.2.01 and 12.1.x) support Java 7 with ojdbc7.jar, and Java 8 with ojdbc8.jar

Oracle 18c supports only Java 8, so the ojdbc driver to be used is ojdbc8.jar

Oracle 19c supports only Java 11, so the odjbc driver to be used is ojdbc10.jar