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LDAP Sync - updating Java caused LDAPS to quit working.

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Article ID: 143685

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

After upgrading Java, LDAP Sync fails with the following error when connecting via LDAPS:

PoolableLdapConnectionFactory WARN   Cannot bind : PROTOCOL_ERROR: The server will disconnect!
2020-01-23 19:00:16.347 [main] c.a.s.l.LDAPSynchronizer ERROR Could not connect to LDAP server. Please check LDAP username and password.
com.automic.sara.ldapsync.exceptions.SynchronizationException: Could not connect to LDAP server. Please check LDAP username and password.
at com.automic.sara.ldapsync.ldap.LDAPService.start(LDAPService.java:89)
at com.automic.sara.ldapsync.steps.InitializeStep.execute(InitializeStep.java:30)
at com.automic.sara.ldapsync.SynchronizationStepChain.execute(SynchronizationStepChain.java:33)
at com.automic.sara.ldapsync.LDAPSynchronizer.run(LDAPSynchronizer.java:58)
at com.automic.sara.ldapsync.LDAPSynchronizer.main(LDAPSynchronizer.java:28)

Environment

Release : 12.2

Component : AUTOMATION ENGINE

Cause

The new installation of Java does not have the correct SSL certificates. 

Resolution

Compare the cacerts from your new installation to the older installation. If these are different, either:

A.) Copy the cacerts from the older java installation to the new one.

B.) Re-install the SSL certificate to the new cacerts folder.