CAPC Data Source Integration Issues After Spectrum Upgraded
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CAPC Data Source Integration Issues After Spectrum Upgraded

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Article ID: 143667

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Upgraded to Spectrum r10.4 (was 10.2). The CAPC data source integration for Spectrum was broken after the upgrade.  In this scenario the customer the upgrade was actually a migration to new hardware and latest operating system.  Therefore new hostnames for Spectrum OneClick.  Modifying the Spectrum data source with new Spectrum OneClick hostname will result in a failure: Data source product ID has changed, create a new entry for this data source.  Customer was also unable to delete the data source (button greyed out) and unable to add a new data source because Spectrum does not exist in the drop down list.

 

Environment

CA Performance Management and CA Spectrum 

Cause

The existing Spectrum data source must be deleted because the new Spectrum OneClick was on new hardware running latest version of the operating system.  

Resolution

Since Spectrum OneClick was migrated, we must delete the existing Spectrum data source.  By default the delete data source is not enabled.  You need to enable the role "Delete Data Source" in CAPC, then delete the Spectrum data source.  Once you create a new Spectrum data source then go back to roles and remove the role right.  Further information about role right are documented under additional information.

Additional Information

Data Source Role rights:

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/performance-management/3-7/administrating/manage-roles-and-user-accounts/role-rights.html#concept.dita_d95bd76b7e5dc336c1e4ed145ece6451edf16b6b_AdministrativeRoleRights