Knowledge search by document ID does not work

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Article ID: 143643

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Updated On:

Products

CA Service Desk Manager KNOWLEDGE TOOLS CA Service Management - Service Desk Manager

Issue/Introduction

After customize the list_KD.htmpl form, adding the Document Id in order to be able to do Knowledge Search by Document Id field, as show in the following image:

 

If a Knowledge Document Search is done directly by the Document Id, it is not working.
Although the document exists, it is not found.

 

Cause

Invalid internal datatype for Document Id field variable.

Environment

Release : 17.2

Component : SDM KNOWLEDGE MANAGEMENT

Resolution

Using a custom list_KD.htmpl form, customized just to include  in the search filter the Document Id,  in a SD 17.2 GER  the issue is reproduced and the search by Document Id is not working, and although the document exists , it is not found.

But issue  is not reproduced any more in a 17.2 GER with RU04.

So, no defect number identified  but issue get fixed in Service Desk version 17.2 GER RU04 and later.

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