Unable to login to Vapp IDM
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Unable to login to Vapp IDM

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Article ID: 143505

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

After migrating data to the vapp, this includes updating the directory and environment XML and adding custom attributes to the schema, User is unable to login to IDM.  credentials have been verified corretly,

The ldap search that goes to the directory is as follows:

[8] 20200121.142542.583 144.2 SEARCH dn="ou=im,ou=ca,o=com" scope=subtree filter=(&(imLoginId=imadmin)(&(1.1=^E\00)(objectClass=imUserAux))) eis=imLoginId uid imPasswordData imEnabledState source="client"
[5] 20200121.142542.583 144.2 RESULT success 0 entries 0 msecs

Environment

Component : IdentityMinder(Identity Manager)

Cause

During the migration of the data, a custom object class was not removed from the user directory search.

The LDAP query results end up with no user entries found, so the user cannot login.

Resolution

To remove the second objectclass, edit the user directory xml as below:

Working:

<ImsManagedObject name="User" description="My Users" objectclass="imUser" pagesize="0" maxrows="0" objecttype="USER">

 

Not Working

 <ImsManagedObject name="User" description="My Users" objectclass="imUser,imUserAux" pagesize="0" maxrows="0" objecttype="USER">