Spectrum Mail registration queue is full warning when running AlarmNotifier instances
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Spectrum Mail registration queue is full warning when running AlarmNotifier instances

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Article ID: 143471

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Updated On:

Products

Spectrum Network Observability

Issue/Introduction

Created a new AlarmNotifier instance but when starting the AlarmNotifier process it reports a large amount of the following message:

AlarmNotifier: Warning: - Mail registration queue is full

Cause

Possible root causes:

- There is a large number of alarms being generated and processed by Notifier

- There is a large number of existing alarms and the $SPECROOT/Notifier/.alarmrc file has the "GET_EXISTING_ALARMS" parameter set to "true".

Resolution

Depending on what is causing the issue will determine what course of action is needed.

1.  If you have started Notifier and receive the error, set the "GET_EXISTING_ALARMS" parameter in the $SPECROOT/Notifier/.alarmrc file to "false" and then restart the AlarmNotifier process 

2.  If there is an excessive amount of alarms being generated, check your SANM filter to decide which alarms to send to the AlarmNotifier and which alarms to not send to the AlarmNotifier.  Filter out any alarms that are not needed

3.  If those alarms are needed but a device is generating an excessive amount of them, put the device in Maintenance Mode until the issue is resolved.

4.  If the message shows after the above has been implemented, kill the Notifier process and let processd restart it.

 

Additional Information

Please reference the "AlarmNotifier" and "Spectrum Alarm Notification Manager (SANM)" sections of the Spectrum documentation for more information:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/spectrum/24-3/managing-client-applications/alarmnotifier/customizing-alarmnotifier/customizing-the-alarmrc-resource-file.html