API-1018 Error in New UX Hierarchies

book

Article ID: 143385

calendar_today

Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

The following error is thrown when trying to edit a newly created hierarchy in the new UX: 

API-1018 : Could not process the request. Refer to error code for more details.

Steps to Reproduce: 

1. In the new UX, click on the Hierarchies link

2. Click on the plus sign to create a new hierarchy

3. Enter a Hierarchy Name (but no ID or Type)

4. Click on the hyperlink for the Hierarchy Name that was entered on the previous step

Expected Results: The hierarchy opens without error and has an option to Import investments. 

Actual Results: The hierarchy appears to open, but there is no option to Import investments and an API-1018 error is thrown. 

Cause

Caused by DE52776

Environment

Release : 15.7.1

Component : CA PPM PROJECT MANAGEMENT

Resolution

DE52776 is targeted to be fixed in our upcoming 15.8 release. 

Workaround: Since the error message occurs because the hierarchy record does not get created until all required fields are entered, enter all of the required fields (Hierarchy Name, ID, and Type) before clicking on the hyperlink of the newly created hierarchy.