Adding a survey URL to the message template in Service Desk Manager 17.x
search cancel

Adding a survey URL to the message template in Service Desk Manager 17.x

book

Article ID: 143349

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After upgrading to 17.1 RU 2 or later, the survey URL changes and adds a msg_digest tag and value. This document explains how to create a new survey URL.

Environment

Release : 17.1 RU 2 and later

Component : SERVICE DESK MANAGER

Cause

The survey URL changes after 17.1 RU 2 and the previous survey URL's will not work.

Resolution

A new way of adding a survey URL to the message template has been introduced which expands to form the survey URL.

The string would look like follows:


#{SURVEY_ID,CNT_ID,CONTEXT_PERSID}


A hash '#' followed by flower brackets. Takes 3 parameters.
1 - SURVEY_ID
2 - CNT_ID
3 - CONTEXT_PERSID

If parameters 2 and 3 are preceded by a '@', then that value needs to be expanded else the value would be replaced as it is in the survey URL.

The above would be expanded as follows:

http://NX_WEB_CGI_URL?OP=DO_SURVEY+SVY_ID=SURVEY_ID+CNT_ID=CNT_ID+CNTXT_PERSID=CONTEXT_PERSID+MSG_DIGEST=message_digest_of_the_url

The value of MSG_DIGEST cannot be generated manually because it is generated based on NX_WEB_CGI_URL automatically. Hence customers need to update the survey URL links in the message templates in the following format:

Existing string:
<a href="https://[EXAMPLE SDM SERVER]/CAisd/pdmweb1.exe?OP=DO_SURVEY+SVY_ID=400001+CNT_ID=@{call_req_id.customer.id}+CNTXT_PERSID=@{call_req_id.persistent_id}"></a>

New string for incident/requests:
<a href="#{400001,@call_req_id.customer.id,@call_req_id.persistent_id}"></a> 

New string for change orders:
<a href="#{400001,@change_id.affected_contact.id,@change_id.persistent_id}"></a> 

New string for change order workflow tasks:

<a href="#{400001,@chg.affected_contact.id,@chg.persistent_id}"></a>