Launch button for Insights (CABI JasperReports) not working on Service Desk

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Article ID: 143274

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When attempting to launch the insights page from Service Desk, the following error occurs:

AHD04405: Internal error of the CA Service Desk Manager system

Stdlog will show the errors below:

ERROR freeaccess.spl 45236 Problem creating Jasper Profile. Error: Exception occurred while creating user

ERROR session.c 9978 Cancelling session servicedesk-627687340:0x3971940 due to interpreter error Problem creating Jasper Profile. Error: Exception occurred while creating user Problem creating Jasper Profile. Error: Exception occurred while creating user

Insights will launch properly if it is done from Xflow or if the Jasper Report page is used.

Cause

The files casm_insights.jks and casm_insights.properties were not copied.

Environment

CA Service Management 17.1 and higher.

Resolution

(1) Navigate to \Program Files\CA\SC\CA Business Intelligence\apache-tomcat\webapps\jasperserver-pro\WEB-INF\config and copy the following files:

casm_insights.jks
casm_insights.properties

(2) Paste the files to CA SDM root installation under the site directory.

For example:

C:\Program Files (x86)\CA\Service Desk Manager\site folder

(3) Restart the Service Desk service

Additional Information

Install and Integrate JasperReports Server r7.2 with CA Service Management 17.3.0.2