Problem starting Spectrum OC/tomcat after OS patching

book

Article ID: 143267

calendar_today

Updated On:

Products

CA eHealth CA Spectrum

Issue/Introduction

After installing Microsoft patches on our SpectroSERVER and OneClick servers and rebooting, we could not log in to OneClick.

It looked like the tomcat service was started, looking in the service control panel in windows but the tomcat log showed that it had not.

Trying to stop tomcat from the service control panel, it did not stop gracefully but when starting tomcat again, it started up ok.

Also a second reboot, it looks like OneClick again starts up ok.

Cause

There was not enough data in the log to pinpoint a problem.

Environment

Release : 10.3

Component : Spectrum Core / SpectroSERVER

Resolution

the only tomcat error should not cause a problem for tomcat to start, so I cannot see why it happened. It would mean that OC cannot contact the landscape.

DistModelManager.addModelDomain: Error starting model watch on domain

I had a similar issue recently, where a restart of the OC server fixed it and it did not cause another problem after that. But I have seen other issues in the past, where the patches had to be uninstalled for a solution. So it is impossible to say with certainty, how to proceed.  

Are these necessary updates? If not, and they can be avoided, then please avoid them. Some corporate policies insist on all MS patches being applied, especially security updates. If this is the case, you can try to install them and hope for a restart of tomcat resolves but please make backups of the system before so that it can be rolled back if needed.