Applications Manager does not start after upgrading to 9.3.x
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Applications Manager does not start after upgrading to 9.3.x

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Article ID: 143258

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Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

After upgrading to Applications Manager version 9.3.x, it fails to start up. Reviewing the RMI logs created at start up shows the following error:

ErrorMsg: AwE-5102 Agent error
Details: Socket[addr=/123.456.789,port=12345,localport=60010]
javax.net.ssl.SSLHandshakeException: No available authentication scheme
        at java.base/sun.security.ssl.Alert.createSSLException(Alert.java:128)
        at java.base/sun.security.ssl.Alert.createSSLException(Alert.java:117)
        at java.base/sun.security.ssl.TransportContext.fatal(TransportContext.java:308)
        at java.base/sun.security.ssl.TransportContext.fatal(TransportContext.java:264)
        at java.base/sun.security.ssl.TransportContext.fatal(TransportContext.java:255)
        at java.base/sun.security.ssl.CertificateMessage$T13CertificateProducer.onProduceCertificate(CertificateMessage.java:945)
        at java.base/sun.security.ssl.CertificateMessage$T13CertificateProducer.produce(CertificateMessage.java:934)
        at java.base/sun.security.ssl.SSLHandshake.produce(SSLHandshake.java:436)
        at java.base/sun.security.ssl.ClientHello$T13ClientHelloConsumer.goServerHello(ClientHello.java:1189)
        at java.base/sun.security.ssl.ClientHello$T13ClientHelloConsumer.consume(ClientHello.java:1125)
        at java.base/sun.security.ssl.ClientHello$ClientHelloConsumer.onClientHello(ClientHello.java:831)
        at java.base/sun.security.ssl.ClientHello$ClientHelloConsumer.consume(ClientHello.java:792)
        at java.base/sun.security.ssl.SSLHandshake.consume(SSLHandshake.java:392)
        at java.base/sun.security.ssl.HandshakeContext.dispatch(HandshakeContext.java:444)
        at java.base/sun.security.ssl.HandshakeContext.dispatch(HandshakeContext.java:421)
        at java.base/sun.security.ssl.TransportContext.dispatch(TransportContext.java:178)
        at java.base/sun.security.ssl.SSLTransport.decode(SSLTransport.java:164)
        at java.base/sun.security.ssl.SSLSocketImpl.decode(SSLSocketImpl.java:1152)
        at java.base/sun.security.ssl.SSLSocketImpl.readHandshakeRecord(SSLSocketImpl.java:1063)
        at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:402)
        at java.base/sun.security.ssl.SSLSocketImpl.ensureNegotiated(SSLSocketImpl.java:716)
        at java.base/sun.security.ssl.SSLSocketImpl.ensureNegotiated(SSLSocketImpl.java:716)
        at java.base/sun.security.ssl.SSLSocketImpl$AppInputStream.read(SSLSocketImpl.java:799)
        at java.base/java.io.ObjectInputStream$PeekInputStream.read(ObjectInputStream.java:2745)
        at java.base/java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2761)
        at java.base/java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:3258)
        at java.base/java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:873)
        at java.base/java.io.ObjectInputStream.<init>(ObjectInputStream.java:350)
        at com.appworx.shared.code.server.B.C(RequestSocket.java:124)
        at com.appworx.server.data.AxRmiServer$3$1.run(AxRmiServer.java:711)

Environment

Release : 9.3.x

Component : APPLICATIONS MANAGER

Cause

This error can occur if the user_keystore and/or user_keystore_config do not exist in the data directory.

Resolution

Make sure that the user_keystore and user_keystore_config files exist in the data directory as described in the documentation linked below.

https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/applications-manager/9-3/Installation_Guide/Applications_Manager_Installation_Advanced_Topics/Using_Custom_SSL_Certificates_for_Connection_Authentication.htmlInstallation Guide > Applications Manager Installation—Advanced Topics > Using Custom SSL Certificates for Connection Authentication