DWH_CMN_PERIOD /timestamp issue causes Jaspersoft Reports to not return data
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DWH_CMN_PERIOD /timestamp issue causes Jaspersoft Reports to not return data

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Article ID: 143193

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Missing or incorrect data in Data Warehouse reports.

 

There are four views in DWH that hold the time period information, deriving the data from DWH_CMN_PERIOD table:
1. DWH_CMN_PERIOD_D_V
2. DWH_CMN_PERIOD_M_V
3. DWH_CMN_PERIOD_F_V
4. DWH_CMN_PERIOD_W_V

Although the DWH_CMN_PERIOD and RPT_CALENDAR table is being populated, one or all of the tables above are not.

 

Environment

All Clarity Versions

Cause

This is due to a mismatch in the server date time stamp between the Application and Database server.
The time stamp will need to match and sync down to the second in order for the data to populate into the views.

The Server team will need to be engaged to synchronize the time between the two servers.

Resolution

The following views derive data from the DWH_CMN_PERIOD table in the DWH database.

nd the range of their data is determined by the Time Slices defined in the PPM Schema. Following is a table, mapping each view to its corresponding Time Slice type.

DWH_CMN_PERIOD_D_V Fiscal
DWH_CMN_PERIOD_M_V Monthly
DWH_CMN_PERIOD_F_V Fiscal
DWH_CMN_PERIOD_W_V Weekly