Cannot activate inactive accounts in the Policy Manager
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Cannot activate inactive accounts in the Policy Manager

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Article ID: 143192

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Updated On:

Products

CA API Gateway API SECURITY STARTER PACK-7

Issue/Introduction

The Policy Manager cannot active an inactivated account which has the "Operator" role.

An Administrator account is used for login to the Policy Manager. The inactivate account is found in the Internal Identity Provider.

On the user's Properties dialog box, the account should be activated by pressing the "Activate" button but it didn't happen.

The "Account Status" stays in "Inactive".

 

Environment

Release : 9.0 and later

Component : API GATEWAY

Cause

The account has never been logged in after its creation and the Maximum Inactivity Period has passed (default: 35 days).

Resolution

PolicyManager cannot activate inactivated accounts which have never been logged in after their creation. Please use one of the following workarounds.

(1) Delete the account and recreate it

(2) Delete the record whose "login" field value is the account name from the "logon_info" table in the "ssg" database

  (Sample SQL statement: delete from ssg.logon_info where login='<account name>';)