Using CSM to obtain product maintenance encounters intermittent failure due to a bad SSL handshake

book

Article ID: 143160

calendar_today

Updated On:

Products

CA Mainframe Software Manager (Chorus Software Manager)

Issue/Introduction

Using CSM to obtain product maintenance encounters intermittent SSL connection failure to supportservices.ca.com .

Cause

Bad handshake between customer's CSM tomcat and supportservices.ca.com server.  Tracing reveals the following:
*****
http-bio-2640-exec-2, received EOFException: error
 http-bio-2640-exec-2, handling exception: javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake
 http-bio-2640-exec-2, SEND TLSv1.2 ALERT:  fatal, description = handshake_failure
 http-bio-2640-exec-2, WRITE: TLSv1.2 Alert, length = 2
 [Raw write]: length = 7
 0000: 15 03 03 00 02 02 28                               .......
0http-bio-2640-exec-2, called closeSocket()
 http-bio-2640-exec-2, IOException in getSession():  javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake.
*****

Environment

Release : 6.0

Component : Chorus Software Manager

Resolution

The intermittent SSL failure was corrected when the customer's firewall proxy allowed communication to supportservices.broadcom.com as well as supportservices.ca.com