Worker Threads metric from SSO to APM vi CA APM for SSO

book

Article ID: 143015

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

The Worker Threads metric in my APM for SSO Investigator console only shows up sporadically in the Health section of the console.  Specifically, it disappears whenever restart the EPAgent and is only available when restarting the associated policy server.  None of the other metrics show this odd behavior.

How can I get to the bottom of this?

 

Cause

Working By Design

Environment

Release : 13.1

Component : APM Agents

Resolution

Worker Thread metric is received only for the first time when PS is started and EPAgent is up and running. There after SSO doesn't send the worker thread metric to EPAgent. Thus when you stop and restart EPAgent, there won't be any worker thread metric data. As SSO is not sending it again.

But when you restart the PS, this worker thread is again sent by SSO to EPAgent. This is when you see the metric again. This is an expected behavior.

Additional Information

 

In the SM Console under settings, add the worker threads. You can find the option under "Performance" Maximum Threads.

By Default this will be set to 8 as per the documentation of SSO.

https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/layer7-identity-and-access-management/single-sign-on/12-52-01/configuring/policy-server-configuration/policy-server-performance.html