Administration Portlet Pages taking too long to load in Clarity PPM

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Article ID: 143013

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

Performance issues with Portlet Pages (Administration) in one or more Clarity environments

Steps to Reproduce:

  1. Navigate to Administration ->Portlet pages
  2. Click on a portlet page

Expected Results: Page returns quickly

Actual Results: Takes anywhere from 5-40 minutes to open any portlet page from the administration side / Create page for new pages.

Cause

This is due to a slow running query on the Database.

  • Note: Generating a PPM Action trace while reproducing the issue can help in determining if there are slow running queries causing the issue
    • See steps to enable action trace at: 9353

Example of a slow running query in this instance may include:

SELECT portlet.id id, cc.name name

FROM cmn_portlets portlet,cmn_captions_nls cc

WHERE cc.pk_id = portlet.id

AND cc.table_name = :"SYS_B_0"

AND cc.language_code = :v0

AND portlet.portlet_view_type_code = :v1

Environment

Release : All Supported Releases

Component : CA PPM SAAS INSTALLATION AND UPGRADE

Resolution

On Premise customers: 

  1. Have the DBA check for slow running queries such as the one referenced above
  2. If any are found, rebuilding the execution plan for any slow running queries can help resolve the performance issue.

Clarity PPM SaaS Customers: Contact Broadcom Support for assistance

Additional Information

See KB 141061 - How to search for known Clarity PPM Issues using Self Service