Hub upgrade from 7.97 to 9.20 still shows old 7.97 version